SIMPLE STEPS TO TUNNEL IPV6 OVER IPV4 IN CISCO PACKET TRACER

In this post i will show you how to configure tunnel ipv6 over ipv4 . Which means connecting two different ipv6 network through tunnel . Check the lab below to understand  it properly . As you can see red markings is ipv6 networks configured but it is interconnected with ipv4 network . So to communicate these two IPv6 networks we will make a tunnel . As you can see in picture below , tunnel is been created over ipv4 . 

ipv6 tunneling over ipv4

ROUTER’S CONFIGURATION

R1

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ipv6 unicast-routing
Router(config)#int fa0/1
Router(config-if)#ipv6 add 2000::1/64
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router(config-if)#exit
Router(config)#router eigrp 1
Router(config-router)#network 1.0.0.0 255.0.0.0
Router(config-router)#exit
Router(config)#int fa0/0
Router(config-if)#ip add 1.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 1.0.0.2 (FastEthernet0/0) is up: new adjacency

 

Now we have to got integer tunnel 0 

 

Router(config)#int tunnel 0

Router(config-if)#
%LINK-5-CHANGED: Interface Tunnel0, changed state to up

Router(config-if)#tunnel source fa0/0   ( Router’s POrt from where this tunnel will start )

Router(config-if)#tunnel destination 2.0.0.2  ( Ip address of router’s port where tunnel will end )
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up

Router(config-if)#tunnel mode ipv6ip
Router(config-if)#ipv6 add 2020::2/64  (  new ipv6 network to this tunnel port ) 
Router(config-if)#exit

STATIC ROUTING 

Router(config)#ipv6 route 2001::/64 2020::1
Router(config)#

 

R2 ROUTER’s CONFIGURATION 

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/1
Router(config-if)#ip add 2.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip add 1.0.0.2 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#router eigrp 1
Router(config-router)#network 1.0.0.0 255.0.0.0
Router(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 1.0.0.1 (FastEthernet0/0) is up: new adjacency

Router(config-router)#network 2.0.0.0 255.0.0.0
Router(config-router)#exit
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 2.0.0.2 (FastEthernet0/1) is up: new adjacency

R3 ROUTER’s CONFIGURATION

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ipv6 unicast-routing
Router(config)#int fa0/0
Router(config-if)#ipv6 add 2001::1/64
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#exit
Router(config)#int fa0/1
Router(config-if)#ip add 2.0.0.2 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router(config-if)#exit
Router(config)#router eigrp 1
Router(config-router)#network 2.0.0.0 255.0.0.0
Router(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 2.0.0.1 (FastEthernet0/1) is up: new adjacency

Router(config-router)#exit

 

TUNNEL CONFIGURATION IN ROUTER R3 
Router(config)#int tunnel 0

Router(config-if)#
%LINK-5-CHANGED: Interface Tunnel0, changed state to up

Router(config-if)#tunnel source fa0/1
Router(config-if)#tunnel destination 1.0.0.1
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up

Router(config-if)#tunnel mode ipv6ip
Router(config-if)#ipv6 add 2020::1/64    (  new IPV6 ADDRESS TO THIS TUNNEL PORT ) 
Router(config-if)#exit
Router(config)#ipv6 route 2000::/64 2020::2
Router(config)#

Now click on Laptop or pc connected to router R3 . Here we have to assign ip to this end device . Go to Desktop > IP COnfiuration and in ipv6 area filled the ipv6 address and its gatteway .

ip configuration in packet tracer

Same goes with the laptop or pc conneted to Router R1 .

Assign correct  ipv6 address and ipv6 gateway .

ip configuration in cisco packet tracer

Now open pc or laptops command prompt Desktop > CommandPrompt

Try to ping or connect another ipv6 address laptop .

I’m using 2001:2 laptop’s command prompt and trying to access 2000:2 .

command prompt in cisco packet tracer

As you can see from the above picture –

  1. 2001:2 now able to connect the other ipv6 address( 2000:2)  when both are interconnected with ipv4 network  . Thats tunnel which is been created for ipv6 . Thats why its been called tunneling ipv6 over ipv4 .
  2. COmmand tracert help you to see from where the package is moving .

 

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s