LEARN HOW TO CONFIGURE LOOPBACK INTERFACE ON CISCO ROUTER

In this post we will learn how to configure loop back interface on cisco routers . Loop back interface are virtual interfaces in cisco routers .They cannot be physically seen but exist and also it never goes down until the whole router is down .

loop back interface on cisco routers

ROUTER’S CONFIGURATION 

ROUTER R1

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int loop1

Router(config-if)#
%LINK-5-CHANGED: Interface Loopback1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up

Router(config-if)#ip address 1.0.0.1 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int loop2

Router(config-if)#
%LINK-5-CHANGED: Interface Loopback2, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up

Router(config-if)#ip address 2.0.0.1 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int se0/0/1
Router(config-if)#ip address 4.0.0.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

Router(config-if)#exit
Router(config)#int se0/0/0
Router(config-if)#ip addres
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
s
% Incomplete command.
Router(config-if)#ip address 3.0.0.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

Router(config-if)#exit
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Router(config)#router rip
Router(config-router)#version 1
Router(config-router)#network 3.0.0.0
Router(config-router)#network 4.0.0.0
Router(config-router)#network 1.0.0.0
Router(config-router)#network 2.0.0.0
Router(config-router)#exit
Router(config)#

 

ROUTER R2

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int loop 5

Router(config-if)#
%LINK-5-CHANGED: Interface Loopback5, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback5, changed state to up

Router(config-if)#ip address 5.0.0.1 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip address 9.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int loop 4

Router(config-if)#
%LINK-5-CHANGED: Interface Loopback4, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback4, changed state to up
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int se0/0/0
Router(config-if)#ip address 6.0.0.1 255.0.0.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
Router(config-if)#exit
Router(config)#int se0/0/1
Router(config-if)#ip address 4.0.0.2 255.0.0.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down
Router(config-if)#exit
Router(config)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

Router(config)#router rip
Router(config-router)#version 1
Router(config-router)#network 4.0.0.0
Router(config-router)#network 5.0.0.0
Router(config-router)#network 6.0.0.0
Router(config-router)#network 9.0.0.0
Router(config-router)#network 10.0.0.0
Router(config-router)#exit
Router(config)#

 

ROUTER R3

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 7.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int loop 3

Router(config-if)#
%LINK-5-CHANGED: Interface Loopback3, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback3, changed state to up

Router(config-if)#ip address 8.0.0.1 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int se0/0/1
Router(config-if)#ip address 6.0.0.2 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

Router(config-if)#exit
Router(config)#int se0/0/0
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

Router(config-if)#ip address 3.0.0.2 255.0.0.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
Router(config-if)#exit
Router(config)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
Router(config)#router rip
Router(config-router)#version 1
Router(config-router)#network 7.0.0.0
Router(config-router)#network 8.0.0.0
Router(config-router)#network 6.0.0.0
Router(config-router)#network 3.0.0.0
Router(config-router)#exit
Router(config)#

Now go to laptop on 7.0.0.0 network and assign ip address , subnet mask and default gateway .

ip configuration on laptops in cisco packet tracer

command prompt in cisco packet tracer

 

 

LEARN HOW TO CONFIGURE PAP CONFIGURATION ON CISCO ROUTERS

LEARN HOW TO CONFIGURE VLAN ON CiSCO SWITCH .

HOW TO CONFIGURE EIGRP ROUTING ON CISCO ROUTERS .

 

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s