HOW TO CONFIGURE EIGRP ROUTING ON CISCO ROUTERS .

In this post we will learn how to configure eigrp routing on cisco router . In my previous post we learn how to configure RIp routing on cisco router . But Rip routing is used when a  company  has maximum fifteen routers . So if company have more than fifteen routers , then EIGRP routing is the best choice .

 

EIGRP stands for enhance interior gateway routing protocol . I got a simple lab for you guys to understand how to configure eigrp on cisco router and for ccna students , you will find it easy to understand in this lab . As you can see there are total six networks in this lab .

eigrp routing in ccna

  • First take three routers and  laptops .

routers and devices

  • Now go to routers and do the following steps :

–   Switch off the routers

–   Select WIC-2T (dual serial port Wan interface card )

–   Now hold and place that card to both empty slots of routers .

–   Switch on the router

  • Place wan card on all three routers .

routers

  • Now select Serial DCE cable from connection section .

serial cable connection

  • Now select router R1 ‘s serial 0/0/0 port

routers and devices

  • And take that other end and connect with  router R2  ‘s  serial0/0/0 port .

routers connection

  • Again take serial DCE cable and select Serial 0/0/1 port of Router R1

routers connection

  • And connect it with Router R3  ‘s serial 0/0/1 port .

routers connection

  • Take serial cable and select one connection to router R3 ‘s serial 0/0/0 port

routers connection

  • And connect it with router R2 ‘s serial 0/0/1 port .

routers connection

  • Select copper cross wire to connect Router R1 and laptop 1 . Connect both with their fast ethernet 0 port .

routers and laptop connection

  • Then comes Router R3 and laptop3 . Connect them also with their Fast ethernet 0 port .

routers and laptop connection

  • Same goes with Router R2 and laptop 2 . Connect both with their Fast ethernet 0 port.

routers and laptop connection

NOW COMES ROUTER CONFIGURATION PART

ROUTER R1
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 1.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int se0/0/0
Router(config-if)#ip address 3.0.0.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
Router(config-if)#exit
Router(config)#int se0/0/1
Router(config-if)#ip address 2.0.0.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down
Router(config-if)#exit
Router(config)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

Router(config)#router eigrp 1
Router(config-router)#network 1.0.0.0
Router(config-router)#network 2.0.0.0

Router(config-router)#network 3.0.0.0
Router(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 3.0.0.2 (Serial0/0/0) is up: new adjacency

 

 

ROUTER R2

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 4.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int se0/0/0
Router(config-if)#ip address 3.0.0.2 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

Router(config-if)#exit

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state
Router(config)#int se0/0/1
Router(config-if)#ip address 5.0.0.1 255.0.0.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down
Router(config-if)#exit
Router(config)#
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

Router(config)#router eigrp 1
Router(config-router)#network 4.0.0.0
Router(config-router)#network 3.0.0.0
Router(config-router)#network 5.0.0.0
Router(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 5.0.0.2 (Serial0/0/1) is up: new adjacency

Router(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 3.0.0.1 (Serial0/0/0) is up: new adjacency

 

ROUTER R3

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 6.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int se0/0/0
Router(config-if)#ip address 5.0.0.2 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

Router(config-if)#exit

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Router(config)#int se0/0/1
Router(config-if)#ip address 2.0.0.2 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

Router(config-if)#exit
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

Router(config)#router eigrp 1
Router(config-router)#network 5.0.0.0
Router(config-router)#network 6.0.0.0
Router(config-router)#network 2.0.0.0
Router(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 5.0.0.1 (Serial0/0/0) is up: new adjacency

%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 2.0.0.1 (Serial0/0/1) is up: new adjacency

 

  • Now go to laptop 3 and provide ip as shown below .

ip configuration in cisco packet tracer

  • Provide ip in laptop 2 too .

ip configuration in cisco packet tracer

  • Same goes with laptop 1 . Provide ip to test eigrp routing is working or not .

ip configuration in cisco packet tracer

Now go to any laptop and select command prompt .

And try to ping with other two laptops .

Like if you are in laptop 1 type –

  • ping 4.0.0.2 
  • ping 6.0.0.2

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s