HOW TO CONFIGURE RIP ROUTING ON CISCO ROUTERS. (cisco packet tracer)

In this post we will learn how to configure rip routing on Cisco routers . If you have more than five routers its difficult to route in all router using static routing . If a small companies have maximum  fifteen routers , Rip routing is best for connection  . But if you have more than fifteen routers then rip routing is a bad idea .

HOW TO CONFIGURE RIP ROUTING ON CISCO ROUTERS ?

  • This is a diagram , in which i’m using four routers with serial ports . This connection have ten networks . Through rip routing we will make connection between pcs having different network .

rip routing in ccna

  • First take four routers and PCS.

router and devices

  • GO to routers .
  • First switch off the router.
  • Then select WIC-2T ( It is a dual -serial interface card , to support a wide variety of electrical interfaces .)
  • Hold and drag that wan card and place one by one to both empty socket .
  • Then switch on the router
  • ADD WAN CARD IN ALL FOUR  ROUTERS .

routers

  • Take cable cross wire under connection section and connect PCS with their routers .
  • Connect both with their fa0/0 ports .

router and pcs connection

  • Again go connection section and select Serial dce cable .

serial cable connection

  • GO to router R1 , select its serial 0/0/0 port

serial ports in routers

  • And connect it with Router R2 serial 0/0/0 port .

serial ports in routers

  • Again take DCE cable and select router R3 ‘ s serial 0/0/1 port

serial ports connection

  • And connect it with router R2′ s Serial 0/0/1 port .

serial ports connection

  • With DCE cable select Router R4 ‘s serial 0/0/0 port

serial ports connection

  • And connect it with ROuter R3 ‘s serial 0/0/0 port

serial pports connection

  • Take again DCE cable and connect both Router R4 and R1 ‘s  serial 0/0/1 port

serial ports connection

serial ports connection

  • Now we will make inner connection
  • Connect both Router R4 and R2 ‘s  serial 0/1/0 port  using DCE cable

serial ports connection

serial ports connection

  • Connect both router R1 and R3 ‘s  serial 0/1/0 port using DCE cable

serial ports connection

serial ports connection

Now Rip Routing part

Router R1

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 3.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int se0/0/0
Router(config-if)#ip address 8.0.0.2 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
Router(config-if)#
Router(config-if)#exit
Router(config)#int se0/0/1
Router(config-if)#ip address 2.0.0.2 255.0.0.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down
Router(config-if)#exit
Router(config)#int se0/1/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
Router(config-if)#
Router(config-if)#exit
Router(config)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

Router(config)#router rip
Router(config-router)#version 1
Router(config-router)#network 3.0.0.0
Router(config-router)#network 8.0.0.0
Router(config-router)#network 10.0.0.0
Router(config-router)#network 2.0.0.0
Router(config-router)#

 

Router R2
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 7.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int se0/0/1
Router(config-if)#ip address 6.0.0.2 255.0.0.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down
Router(config-if)#exit
Router(config)#int se0/0/0
Router(config-if)#ip address 8.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

Router(config-if)#exit
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Router(config)#int se0/1/0
Router(config-if)#ip address 9.0.0.1 255.0.0.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
Router(config-if)#exit
Router(config)#
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

Router(config)#router rip
Router(config-router)#version 1
Router(config-router)#network 7.0.0.0
Router(config-router)#network 6.0.0.0
Router(config-router)#network 9.0.0.0
Router(config-router)#network 8.0.0.0
Router(config-router)#

 

Router R3

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 5.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int se0/0/0
Router(config-if)#ip address 4.0.0.2 255.0.0.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
Router(config-if)#exit
Router(config)#int se0/0/1
Router(config-if)#ip address 6.0.0.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

Router(config-if)#exit

Router(config)#int se0/1/0
Router(config-if)#ip address 10.0.0.2 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

Router(config-if)#exit
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

Router(config)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Router(config)#router rip
Router(config-router)#version 1
Router(config-router)#network 5.0.0.0
Router(config-router)#network 4.0.0.0
Router(config-router)#network 6.0.0.0
Router(config-router)#network 10.0.0.0
Router(config-router)#

 

Router R4

 

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int se0/0/0
Router(config-if)#ip address 4.0.0.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

Router(config-if)#exit
Router(config)#int se0/0/1
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Router(config-if)#ip address 2.0.0.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

Router(config-if)#exit

Router(config)#int se0/1/0
Router(config-if)#ip address 9.0.0.2 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

Router(config-if)#exit
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

Router(config)#int fa0/0
Router(config-if)#ip address 1.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#router rip
Router(config-router)#version 1
Router(config-router)#network 4.0.0.0
Router(config-router)#network 9.0.0.0
Router(config-router)#network 1.0.0.0
Router(config-router)#network 2.0.0.0
Router(config-router)#

 

  • In rip routing we inform router to which network they are connected .
  • Like in Router R1 it is connected to network 3 , 2, 8 and 10 .
  • Same way to other routers . Routers communicate with each other and connect each other with their same network sharing path.
  • If we want to connect pc2 and pc3 they are many way . It can go through router R4 or router R2 . But in Rip routing , it takes short path to reach destination  . So if pc2 want to connect to pc3 , package will go from router R1 to router R3 .

rip roting on routers

  • On right pane you will see package symbol . Select it .
  • Then go to pc2 and give destination to pc3 by clicking it.

package box in cisco packet tracer

  • Then open real time to see how package goes  .

rip routing on routers

  • If package is going directly to router R3 from router R1 that means rip routing is working . If package is taking some other path to reach that means you made some mistake .

rip routing on routers

 

Don’t hesitate to comment if you got any problem .

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s