HOW TO CONFIGURE SINGLE ROUTER TO ACT AS A MULTI DHCP SERVER (cisco packet tracer)

In this post we will learn how to configure router as a multi dhcp server . Means One router will provide ip address to every systems .So you don’t have to configure every router to provide ip address to connected pool .

How to configure router as multi DHCP server

As shown above we will configure Router R1 to act as multi DHCP server .

  • First take three routers , switches and six systems.

routers switches and laptops

  • Now go to connection section and select copper straight wire .
  • Straight copper wire is used to connect  switches & Systems (end devices) or switches & routers .
  • Copper cross wire is used to connect Routers & Routers or Switches & Switches or Router and Laptops (end devices ).
  • So select copper straight wire .

connection cable

  • Select laptop 1 and connect one point with Fast Ethernet 0

pc connection port

  • Then go to Switch and select switch’s Fast Ethernet 0/1 port

3

  • Again take straight wire and connect pc(laptop 2) and switch . But this time connect with switch’s Fast Ethernet 0/2 port .

4

  • Now with Straight wire connect  one point with switch’s Fast Ethernet 0/3 port .

STATIC ROUTING CONFIGURATION USING 2 ROUTERS

  • With Router’s Fast Ethernet 0/0 port .

How to configure router as multi DHCP server

  • Connect other two routers with their switches and systems resp.
  • But in Router R2 , We have to give extra port of ethernet . Go to Router R2
  • Switch off the router .
  • Select WIC -1ENET from left pane .
  • Now click and hold that port and drag it to empty socket .
  • Turn on the router
  • I’m connecting my switch with router’s ETH0/0/0 port .

How to configure router as multi DHCP server

  • Take copper straight wire and select Router R1 and and it’s Fast Ethernet 0/0 port .

How to configure router as multi DHCP server

  • And take that wire to router R2 and it with R2’s Fast ethernet 0/0 port .

How to configure router as multi DHCP server

  • Again take copper straight to wire and select R2’s Fast Ethernet 0/1

How to configure router as multi DHCP server

  • And connect to  R3’s Fast Ethernet 0/1 .

How to configure router as multi DHCP server

Now in Router R1 run these command .

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 1.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int fa0/1
Router(config-if)#ip address 2.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

Router(config-if)#exit

how to configure router as multi dhcp server

IN Router R2 Run below command to assign ip address to ports .

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int eth0/0/0
Router(config-if)#ip address 3.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip address 2.0.0.2 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int fa0/1
Router(config-if)#ip address 4.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

Router(config-if)#exit

how to configure router as multi dhcp server

IN Router R3 .

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 5.0.0.1 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int fa0/1
Router(config-if)#ip address 4.0.0.2 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router(config-if)#exit

how to configure router as multi dhcp server

First we will do routing before DHCP configuration

Router R1

Router(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2
Router(config)#ip route 4.0.0.0 255.0.0.0 2.0.0.2
Router(config)#ip route 5.0.0.0 255.0.0.0 2.0.0.2

Router R2

Router(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1
Router(config)#ip route 5.0.0.0 255.0.0.0 4.0.0.1

Router R3

Router(config)#ip route 3.0.0.0 255.0.0.0 4.0.0.1
Router(config)#ip route 2.0.0.0 255.0.0.0 4.0.0.1

Router(config)#ip route 1.0.0.0 255.0.0.0 4.0.0.1

Now comes dhcp configuration

ROUTER R1

Router(config)#ip dhcp pool one
Router(dhcp-config)#network 1.0.0.0 255.0.0.0
Router(dhcp-config)#default-router 1.0.0.1
Router(dhcp-config)#exit

Router(config)#ip dhcp pool two
Router(dhcp-config)#network 3.0.0.0 255.0.0.0
Router(dhcp-config)#default-router 2.0.0.1
Router(dhcp-config)#exit

Router(config)#ip dhcp pool three
Router(dhcp-config)#network 5.0.0.0 255.0.0.0
Router(dhcp-config)#default-router 2.0.0.1
Router(dhcp-config)#exit

For network 1.0.0.0  Its default router port is 1.0.0.1

For network 3.0.0.0 &  5.0.0.0 Port 2.0.0.1 will help to provide ip address.

dhcp pool in ccna

  • Go to laptop1 >DESKTOP > IP configuration
  • Click on Dhcp .

dhcp ip request in ccna

  • Go to laptop 2 .
  • Click on Dhcp , Sytem will request ip address from Router R1 which is DHCP server .
  • IP address and related information will be filled automatically .

dhcp ip request in ccna

  • Go to PC3 and click on DHCP to request ip address

dhcp ip request

  • Then go to PC4 and click on Dhcp to request ip address from Router R1

dhcp ip request

  • Go to Laptop 5 and click on DHCP . If you see “dhcp request successful” this means Dhcp server is working fine on this network .

dhcp ip request

  • At last go to Laptop 6 and click on dhcp .

dhcp ip request

3 thoughts on “HOW TO CONFIGURE SINGLE ROUTER TO ACT AS A MULTI DHCP SERVER (cisco packet tracer)

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s